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INTRODUCTION :

Some definitions :

With Paint effect you can paint on surfaces or in space. The brushes which you use are aerographes,
effects of matters or trees, flowers or hair...

A stroke of pencil, or a blow of brush (STROKE) will be in MAYA space a collection of curves
NURBS. (We will deposit seeds in a furrow...)

A collection of attributes is applied to each brushes(TEMPLATE BRUSH)

These brushes can be saved and thus become PRESET BRUSHES

Our objective during this class :

We will introduce the principal possibilities of creation of brush as well as even principal tools for
animations of plants.

First we will see connexions of Paint effect.

Comment PFX est une Palette 2D.

Comment travailler dans l'espace 3D : planter des arbes des fleurs dans un paysage.

Comment animer les éléments.

ATTRIBUTS CONNEXIONS :

By default " STROKES " are invisible Nurbs curves.
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Visor-> Grasses->Corn2.mel
Draw in Perspectiv view
Open Hypergraph. Click on the curve with the right key of mouse to chose in the Pop Up
Menu l'option Show. The curve is visible.
Show curve CV's,(Click just near the curve with the right key of mouse to open a marking
menu where you choose option Control Vertex.Vous will see a great quantity of points
In order to better handle this curve it is good " to simplify it ": select the curve, then the menu
Paint Effect->CurveUtilities-> Simplify Stroke Path Curve.
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A brush can be connected with a curve :

Create a curve and keep it selected

Choose a brush (Visor-> Grasses->Corn2.mel)
Connect this brush to this curve : PaintEffect->CurveUtilities->Attach Brush to curve

PAINT IN 2D (Canvas) :

We will try out the possibilities of painting of Paint effect. We propose here to carry out an this kind
image:
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Définition and creation of brushes :

Preparation of the workin space :

Options-> ShowOnlyViewingPlane
Open shelf; MarkingMenu ->Markingmenu est ->Shelf

Go in canvas mode : Key8
The cursor in this window, activate with the right key of mouse the popUpMenu and choose
option Paint->paintcanvas, you obtain this worhink space :
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NOTICE ON THE USE OF A SENSITIVE TABLET:

The cursor in this window, activates with the right key of mouse the popUpMenu and chooses the
option Paint->UseSTylusPressure=ON

In PFX the variation of theline is controlled by the pressure of the cursor. The limits of pressures
can be defined in PaintEffects-> Paint effcets tools :
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Brushes types and acces to presets :

You have access has a whole of already prepared brushes :

Activate the Visor ( Window->Visor)
Then go in the repertory /aw/MAYA2.5/brushes

Pour rendre plus facile le choix des brosse vous pouvez vous fabriquer des "shelf'. Pour les remplir il
suffi de cliquer sur l'icone du preset puis déplacer vers le shelf.

To make easier the choice of the brush you can manufacture " shelf'. To fill them it been enough to
click on the icone to the preset then to move towards the shelf.

 PRESS/RELEASE M STROKE OFFSET ON SURFACE

 PRESS/RELEASE b SIZE OF STROKES

 KEY 8 Open PAINT EFFECT : "CANVAS"

THE PRINCIPAL SHORT CUTS OF PAINT EFFECT

PAINT BRUSH SETTING

From the visor select a brushe (like pens->calligraphics)
Let us notice that one can create a brush, and one can then start from initial paraméters while
making:: Paint Effects->ResetTemplateBrush
Open the Brushe tool settingof a brushe while clicking on the following icone:
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Comment on the principal attributes:

Brush Type use a brush in brush mode, aerographe or marker allow: Paint a rubber, a smear brush
or blur

Global scale allows to define the size of the brush, the key B allows to regulate this value
interactively.

Channels : You save the canvas on which you paint in IFF format.You can choose to save the
colors plans, the plan masks or the plan of depth(zdepth) depth is the distance from the object to the
camera (expressed in levels of gray). In order to understand its use please choose a brush in pencils :
goopinkred then to try out the combinations following

OFFON

ONON

OFFOFF

MODIFY DEPTHDEPTH

( ON ON is well adaptee for grass and the foliage...)

To save images of Canvas :

With the third button of mouse you will choose in the popup menu canvas->save ou canvas
save as. Or you will choose the icone file being in the window canvas right of the icone of
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opening of the window "Template brush editor"

If the mask is active the icone canvas will allow to post the mask of the image.(white circle on black
background)

During a work you can activate or not the use of the mask. The mask and the colors plans can thus
be different...

Brushes profiles :

Brush Width : To define the size of the brush in MAYA unit

Softness : Allows to treat the edge of the brush

Flantess1 : allows to treat the distribution of the pixels has the interior of the brush
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Stamp density : spacing enters the brushes

Screnn path width( this option does not have effects in canvas mode)

In Perspective view move in space to show with screen path =ON you respect the working
scale of Maya

Shading :

You will give here the color, the transparency and the incandescence of a brush ;

Blur intensity is active that if the type of the brush is defined like blur.

Edge antialiasing antialiasing of the edge of the brush. (Test a brush of softness=0 with and
without antialiasing)

NOTICE : You can obtain additive effects of color if you give a color to the transparency :
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Brushes textures :

Textures of brushes can be of dammier type, degrades out of U or v or fractal.

Test some modifications of parameters :
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The Part Shadow Effects will make it possible to create a shade of the feature: to try to modify
the distance, the transparency
In the Glow part. give a color an intensity (glow) and a dimension (Spread)

Restore brushes type :

When we work on image in canvas mode one an image, often we needs to erase a part or in
transparency the effect of brush which one has just pose.

In this case the technique of brush by restoration of the basic image and not of the background
proves to be necessary.

This type of brush is on Eclipse or StudioPaint.

This example shows how in Paint Effect we can produce this type of brushe

Here, we will take the example of the modification of a mapping of file on a surface.

NOTICE ON THE PREPARATION OF THE MAPS:

It is more practical to create two files of the image than you will use:
One for the map.
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(In our example : MapRuisdael_Raleigh_Spruces_warefall.jpg ).

One other for the sroke

(In our example : StrokeRuisdael_Raleigh_Spruces_warefall.jpg ) .

Map an image on a surface :

Go in perspectiv vue
Create a plan: Create-> NurbsPrimitive
Create a directional lighte : LIGHT>CreateDirectional Light
Direct the lumiére ( rendering mode : key7, and keyT)
Open HYPERSHADE, Choose a " material Blinn " and map on the color the file which
you prepared :

Apply this shader on the surface

Create restore brushe

On the perspective window activate Effect Paint by activating key 8
The cursor positioned in this window press on the right key of mouse
and choose the option Paint->PaintCanvas to test the manufacture of
your brush.
First,You can initialize the values of a brush:Paint Effects->ResetTemplateBrush
Open the window of Brushes attributs :

If for example you want a brush of this type:
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You must have the parameters of following attributes:
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Save this brush like new " preset " in a shelf : Paint Effect-> Save Brush Preset

Clean the canvas, thendesactivate the canvas window of paint Effect while pressing on key 8.
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Opening Painteffect window :

Divide your space of work into two parts : Panel->Layouts>2 side by side
On the right-hand window activate Effect Paint by key 8
The cursor positioned in this window press on the right key of mouse
Choose option Paint->PaintCanvas
From Window->Visor click and dragg the file of map on the Canvas window

Thus, in the window of right-hand side you have your geometrie with the map, in the canvas
the map which you can work :
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You can work in the surface of the canvas:
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The update of the file map is done by activating the icone folder of the canvas window :

The brush restores makes it possible to erase the parts which one has just worked by finding
the bottom that one has map on surface:



pfx class imagina 2000 file:///G:/preparation/pfx/evpfxclass.html

Page 18 sur 28 Wednesday, March 08, 2000 10:23:25

TO PAINT IN A 3D SPACE 3 D

PAINT EFFECT can paint on a surface or well in space.

Choose in visor a grass brushe
Open perspectiv view .Draw a grass line...
You notice that as long as you draw you will see the grass , As
soon as you stop viewing is simplified.
Move camera,
Now, select a stroke and move it in space
If you want to plant a field, select one of Stroke , do EDIT->DUPLICATE option : give a
displacement in xyz, a number of repetition, in instance mode.

If you open attribut editor of the selected stroke, you have access to position node :
strokegrassclump1. You can position or animate the stroke in space.

Withe shape node : strokeShapegrassClump1. You define the attributes described the qauntite and
the characteristics of seeds planted along the furrow:
Sample density : spacing of the seedlings

seed : a number of varieties of seeds.

Draw Order : it is the set of priorities of the features of brushes. (>0: in front of. <0: behind)

Surface offset : .When one draws on a surface, it is the distance from the feature compared to
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surface.

smoothing : Smoothing of the curve CV's

This option makes it possible to deaden the effects of step

In top vue draw a curve whith many "zigzag"
modify smoothing value

Motion Blur : must be uses in animation and in returned using the blur 

definition of attributs for orientation and length of brushe along a curve :

Choose in visoe a fire brushe
Open Perspectiv view.Draw a line
Modify end Max Clip value to 0, apply a keyframe
Modify end Max Clip value to 1, apply a keyframe
Play : a trail of fire lengthens...

Normal direction will direct shoots...

TUBES BRUSHES ATTRIBUTS

Les plantes et les arbres sont de type tube. On a Accès a leurs paramétrés de formes dans le noeud
de brosse sous l'item Tubes.

The plants and the trees are of type tubes. There are Accès their
parameterized of forms in the node of brush under item Tubes.

Creation of a brush tubes basic: the stick

Tube Completion On : The tubes are of the same length along the feature of the brush

Tube completion Off the tubes are reduced along the stroke

Go in canvas mode clicking 8 Key
Open Attribut editor
Do : Painteffect->Reset tamplate brush
Draw a stroke on canvas or use a tree brush and draw a stroke on canvas
In attribut brushe in part tube choose these parameters :
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Save this brush in your shelf
Paint effect ->save presets

A good way of evaluating the modifications of parameterized is to choose this organization of work,
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To post the result of the modifications quickly, configure the
values of resolution rather low
Places the cursor in the Canvas and press on the right key of
mouse to activate Resolution=50%.

Verify if STRoke Refresh show Rendered)

Test valeures of this type by activating the creation of branches:
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Growing attributs :

You can define the orintation and the number of branches

littles branches

the leaves

the flowers

the buds

Notice about the leaves

A scan of Leaves can be mapped. Under leaves desactivate LeafUseBranch Text an reach an image
of leave

Its same things for flowers

ANIMATION

The animation of the elements is done by deformation of the tubes or by application of dynamic to
the tubes. Under item the tube you will find under behaviour :

Displacement, forces, turbulence, Spiral, Twist

Example of animation of a tree by turbulence

In Perspectiv view create a plan: Create-> NurbsPrimitive->plane
Choose an right scale
To plant a tree on this surface made initially : PaintEffects->Makepaintable
FromVisor , choose a tree and plant it!...Select the tree.
Then open the attribute editor. Under the node of form of the tree
(strokeShapeTree_canvas for example)
You increase the quality of the brushe by using : ObjectDisplay->Display quality
Under the node of the brush in the part Tubes, under behaviuor you find the Turbulence item,
to give various values to see the influence. On each of these values you can give a key of
animation.
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Example of animation of a tree by a curve

(From the example preceding).
Create a curve on the basis of the bottom of the tree and going to the top of the tree
Select the tree and the curve.
To activate this curve of control made
PaintEffects->CurveUtilities->SetStrokeControlCurve

Curve Follow, Curve Attract, Curve Max dist are the values which will influence the curve.
Sélect curve CVs . By moving them you will modify the shape of the tree:
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If you select the plan and that you to move it the tree will be countered by the curve. 

Tentacules animation

open file pfx_testla.mb
If you play animation you see that lights are animated then a smaller ball appears...
Select the named sphere powerball and return the " paintable "
Paint on this surface some electric flashes



pfx class imagina 2000 file:///G:/preparation/pfx/evpfxclass.html

Page 26 sur 28 Wednesday, March 08, 2000 10:23:28

Play animation
Go to frame 100
Sélect strokes
(Edit->Select all by type-> Strokes) and courbe37
Do : Paint Effects -> Curve
Utilities -> Set Stroke Control Curves
Electricity will be attracted by the rising sphere: to play animation
Around the frames 100 and 150, select the little sphère
Made it "paintable", to paint electricity on it
From attribut editor of this brush, modify shading values to obtain pink and violet flashes...
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Now we will define the moment or the second ball will start has to establish

Flow speed : Defines the speed (in cycles a second) of the effects of shearings, torsions, as well as
the displacement of textures along the animated tubes. The positive numbers make a flow starting
from the base. The negative numbers make them develop and rise from the end towards the base.

Stroke time allows the growth animation of the beginning to the end of the curve " stroke ".All that
in in the time varation defined by start time and end time.

Clip time : Defines the beginning and the end of the animation of the tube.

Start time and end time : are expresses in seconds. If your unit of time is defined in 24/s for
example (Options > General Preferences > Units), and you want to start has keys 80 you must then
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enter an expression in the start time field.( write: =80.0/24 (the key must be in float : 80.0))


