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INTRODUCTION :

Quelques définitions :

Avec paint effect vous pouvez peindre sur des surfaces ou dans l'espace. Les brosses que vous
utilisez sont des aerographes, des effets de matières ou encore des arbres, des fleurs ou des
cheveux...

Un trait de crayon, ou un coup de pinceau (STROKE) sera dans l'espace MAYA une collection
de courbes NURBS. (En quelque sorte on trace un sillon dans lequel seront déposées des
graines...)

Chacun des trait de pinceau crée une nouvelle brosse (BRUSHES), à laquelle une collection
d'attributs est appliquée (TEMPLATE BRUSH)

Ces brosses peuvent être sauvées et deviennent ainsi des PRESET BRUSHES

Notre objectif durant cette classe :

Il sagit ici d'introduire les principales possibilités de création de brosse ainsi que de voire les
principaux outils d'animations de plantes. Nous évoquerons principalement les points suivants:

Dans un premier temps nous verrons comment sont connectés les attributs de Paint effect.

Comment PFX est une Palette 2D.

Comment travailler dans l'espace 3D : planter des arbes des fleurs dans un paysage.

Comment animer les éléments.

CONNEXIONS DES ATTRIBUTS :

Par défaut les courbes "STROKES" sont des courbes Nurbs
invisibles



.

• Visor-> Grasses->Corn2.mel

• Dessinez en Vue Perspective

• Ouvrez l'Hypergraph. Cliquez sur la courbe avec la touche droite de la souri pour choisir
dans le Pop Up Menu l'option Show. La courbe est visible.

• Affichez les CV's de la courbe, (le curseur juste à côté de la courbe, appuyez sur la
touche droite de la souri pour faire apparaître un marking menu ou vous choisirez
l'option Control Vertex.Vous verrez une grande quantité de points.

• Afin de mieux manipuler cette courbe il est bon de la "simplifier" : sélectionnez la
courbe, puis le menu Paint Effect->CurveUtilities-> Simplify Stroke Path Curve.

• 



Une brosse peut être connectée à une courbe :

Créez une courbe et gardez la sélectionnez

Choisissez une brosse (Visor-> Grasses->Corn2.mel)

Connectez la brosse à la courbe en faisant : PaintEffect->CurveUtilities->Attach Brush to
curve

PEINDRE EN 2D (le mode Canvas) :

Nous allons expérimenter les possibilités de peinture de Paint effect.

Nous proposons ici de réaliser une image de ce genre :



Définition et création de brosses :

Préparation de l'espace de travail :

• Options-> ShowOnlyViewingPlane

• Ouvrir le shelf ; MarkingMenu ->Markingmenu est ->Shelf

• Passage en mode canvas : touche 8
• Le curseur positionné dans cette fenêtre, activez avec la touche droite de la souri le

popUpMenu et choisissez l'option Paint->paintcanvas, vous obtenez cet espace de
travail :



REMARQUE SUR L'UTILISATION D'UNE TABLETTE SENSIBLE A LA PRESSION :

Le curseur positionne dans cette fenêtre, activez avec la touche droite de la souri le popUpMenu
et choisissez l'option Paint->UseSTylusPressure=ON

Dans PFX la variation du trait se maîtrise par la pression du curseur. Les limites de pressions
peuvent être définies dans PaintEffects-> Paint effects tools :



Types de brosses et accès aux presets :

Vous avez accès a un ensemble de brosses déjà préparées :

• Activez le Visor ( Window->Visor)

• puis allez dans le répertoire /aw/MAYA2.5/brushes

Pour rendre plus facile le choix des brosses vous pouvez les placées dans les "shelf'. Il suffit de
cliquer sur l'icône du preset puis déplacer vers le shelf.

 OUVRIR PAINT EFFECT : "CANVAS"  KEY 8

 TAILLE DE LA BROSEE  PRESS/RELEASE
b

 OFFSET DE LA BROSSE SUR
UNESURFACE

 PRESS/RELEASE
M

LES PRINCIPAUX RACCOURCIS CLAVIERS DE PAINT EFFECT

Créer une brosse (PAINT BRUSH SETTING)

• Sélectionnez une brosse a partir du visor, par exemple pens->calligraphics

• Remarquons que l'on peut créer une brosse, et l'on peut alors partir de paramétres initiaux



en faisant : Paint Effects->ResetTemplateBrush

• Ouvrez la fenêtre de fabrication des attributs d'une brosse en cliquant sur l'icone
suivante :

Commentaire sur les principaux attributs :

Brush Type permet d'utiliser une brosse en mode pinceau, aerographe ou marker : Paint. une
gomme, ou une brosse de mélange (smear) ou encore de flou (Blur)

Global scale permet de définir la taille de la brosse, la touche b permet de régler cette valeur
intéractivement.

Channels : Le "canvas" (la toile...) que vous peignez peut être sauvé au format IFF. Vous
pouvez choisir de sauver les plans couleurs, le plan masque ou le plan de profondeur (zdepth)(
depth est la distance de l'objet a la camera (exprimée en niveaux de gris)

Afin de comprendre son utilisation veuillez choisir une brosse dans pencils :goopinkred puis
expérimenter les combinaisons suivantes

DEPTH MODIFY DEPTH

OFF OFF

ON ON



ON OFF

(La combinaison ON ON est bien adaptée pour l'herbe et le feuillage....)

Pour sauver des images du Canvas :

• Avec le troisième bouton de la souri vous choisirez dans le popup menu canvas->save ou
canvas save as. Ou bien vous choisierez l'icone dossier se trouvant dans la fenêtre canvas
justeà droite de l'icône d'ouverture de la fenêtre "Template brush editor"

Si le masque est active l'icone du canvas permettra d'afficher le masque de l'image.(Cercle blanc
sur fond noir).

Au cours d'un travail vous pouvez activer ou non l'utilisation du masque. Le masque et les plans
couleurs peuvent donc être différents...

Profil des brosses :

Brush Width : Définir la taille de la brosse en unité MAYA

Softness : Permet de traiter le bord de la brosse



Flatness1 : permet de traiter la répartition des pixels a l'intérieur de la brosse

Stamp density : réglé l'espacement entre les brosses

Screnn path width ( cette option n'a pas d'effets en mode canvas)

• Allez en perspective et déplacer le curseur dans l'espace pour montrer qu'avec screen
path =ON vous respecter l'échelle de travail de MAYA.

shading :



Vous donnerez ici la couleur, la transparence et l'incandescence d'une brosse ;

Blur intensity est actif que si le type de la brosse est défini comme blur.

Edge antialiasing traite de l'antialiasing du bord de la brosse. (Essayez une brosse de softness=0
avec et sans antialiasing)

REMARQUE : Vous pouvez obtenir des effets de couleurs additives si vous donnez une couleur
à la transparence :

Texture des brosses:

Les textures de brosses peuvent être de type dammier, dégradé en u ou v ou bien fractal.

• Essayez quelques modifications de paramétres :



• La partie Shadow Effects permettra de créer une ombre du trait : essayer de modifier la
distance, la transparence

• Dans la partie Glow . donner une couleur une intensité (glow) et une dimension (Spread)

Brosse de type restaure:

Lorsque l'on travaille sur image en mode "Canvas" on a souvent besoin d'effacer une partie ou en
transparence l'effet de brosse que l'on vient de poser. Dans ce cas la technique de brosse par
restauration de l'image de fond et non du fond de page (background) s'avère nécessaire. Ce type
de brosse se trouve sur Eclipse ou StudioPaint.

L'exemple suivant montre comment dans Paint Effect on peut réaliser des brosses ce type.

Ici, nous verrons aussi comment modifer un "mapping" de fichier sur une surface.

Remarque sur la préparation des mappes :

Il est plus pratique de créer deux fichiers de l'image que vous allez utiliser :



Une pour la mappe.

(dans notre exemple : MapRuisdael_Raleigh_Spruces_warefall.jpg ).

Une que l'on utilisera pour la brosse .

(dans notre exemple : StrokeRuisdael_Raleigh_Spruces_warefall.jpg ) .

Mapper une image sur une surface :

• Se mettre en vue perspective

• Créez un plan : Create-> NurbsPrimitive

• Créez une lumière directionnelle et éclairez la surface : LIGHT>CreateDirectional
Light

• Orientez la lumiére ( en mode de rendu : touche 7, puis touche T)

• Ouvrez la fenêtre HYPERSADE, Choisissez un "material Blinn" et "mappez" sur la
couleur le fichier que vous avez préparé :

• Appliquez ce shader sur la surface sur la surface.

Créer la brosse restaure

• Sur la fenêtre perspective activez paint Effect en activant la touche 8

• Le curseur positionné dans cette fenêtre appuyez sur la touche droite de la souri

• et choisissez l'option Paint->PaintCanvas pour tester la fabrication de vos brosse.

• Vous pouvez d'abord initialiser les valeurs d'une brosse : Paint Effects-
>ResetTemplateBrush

• Ouvrez la fenêtre de fabrication des attributs d'une brosse :



• Si par exemple vous voulez une brosse de ce type :

• Vous devez avoir les paramètres d'attributs suivants :



• Sauvegarder cette brosse comme nouveau "preset" dans le Shelf : Paint Effect-> Save
Brush Preset



• Nettoyer le canvas, puis désactivez la fenétre de canvas de paint Effect en appuyant sur la
touche 8.

Ouverture de la fenêtre de PAINT EFFECT.

• Diviser votre espace de travail en deux parties : Panel->Layouts>2 side by side

• Sur la fenêtre de droite activez paint Effect en activant la touche 8

• Le curseur positionné dans cette fenêtre appuyez sur la touche droite de la souri et
choisissez

• l'option Paint->PaintCanvas

• A partir du Window->Visor cliquez draggez le fichier de map sur la fenêtre Canvas



• Ainsi donc, dans la fenêtre de droite vous avez votre géométrie avec l'image mappée,
dans le canvas la mappe que vous pouvez travailler :

• Vous pouvez travailler dans la zone du canvas :



• La mise a jour du fichier mappe se fait en activant l'icone folder du canvas :

• La brosse restaure permet d'effacer les parties que l'on vient de travailler en retrouvant le
fond que l'on a mapper sur la surface :



PEINDRE DANS UN ESPACE 3 D

PAINT EFFECT peut peindre sur une surface ou bien dans l'espace.

• Choisissez dans le visor une brosse herbe

• Ouvrez une fenêtre de perspective.Dessinez une ligne d'herbe....

• Vous remarquez que tant que vous dessinez vous verrez tout les brins d'herbes, Des que
vous arrêtez l'affichage se simplifie.

• Bougez votre camera,

• Sélectionnez maintenant une "stroke" et déplacez la dans l'espace

• Si vous voulez planter un champ ,alors sélectionnez une des Stroke puis faites EDIT-
>DUPLICATE option : donnez un déplacement en xyz, un nombre de répétition, le tout
en instance...

Si vous ouvrez l'attribut editor de la "stroke selectionnee", vous remarquez que vous avez accès
aux noeud de position : strokegrassclump1. Vous pouvez positionner ou animer le trait de
pinceau dans l'espace.

Noeud de forme : strokeShapegrassClump1. Vous définissez les attributs décrivaient la qauntite
et les caractéristiques des graines plantées le long du sillon :



Sample density : espacement des plants

seed : nombre de variétés de graines.

Draw Order : c'est l'ordre de priorité des traits de pinceaux. (>0 : devant. <0 : derrière)

Surface offset : Lorsque l'on dessine sur une surface , c'est la distance du trait par rapport a la
surface.

smoothing : Lissage des CVsde la courbe :

L'utilisation cette option permet d'amortir les effets de marche

• En vue de dessus dessinez une courbe tres en "zigzag"

• Modifiez la valeur de smoothing

Motion Blur : doit être utilise en animation et en rendu utilisant le blur

Attributs deffinisant l'orientation et la longeur des plantations le long de la courbe:

• Choisissez dans le visor une brosse feu

• Ouvez une fenêtre de perspective.Dessinez une ligne d'herbe....

• Modifiez les valeurs de end Max Clip a 0, appliquez une clef d'animation

• Modifiez les valeurs de end Max Clip a 1, appliquez une clef d'animation

• Jouez l'animation : une traînée de feu s'allonge...

Normal direction orientera les pouces...

Attributs faisant varier la taille des graines le long du trait de pinceau.: Pressure mapping

Si vous utilisez une brosse sensible à la pression, vous pouvez faire varier "l'intensité de chacune
des tailles" par le dessin d'une courbe



• Choisissez dans le visor une brosse herbe

• Ouvrez une fenêtre de perspective.Dessinez une ligne d'herbe....

• Créez la courbe de pression comme suit :

• PaintEffect >CurveUtility> MakePressureCurve (option).

• La fenêtre d'outil d'ajustement de pression de s'ouvre. Définissez le nombre de points de
commande (Control Point) que vous désirez au long de la courbe. Offset Scale indique la
position maximum des points. En appuyant sur le bouton Create, vous créez une courbe
de pression positionne a la normale de la courbe de peinture

• Noter qu'une expression est créée quand vous créez la courbe.

• Editer la courbe de pression comme suit :

• Entrer dans le mode de choix de CV. La position de ces CVs affecte les
valeurs de pression.

• Quand vous êtes satisfaits des nouvelles valeurs de pression, vous
pouvez enlever la courbe de pression. Elle n'est plus nécessaire.

• Sélectionnez le trait de pinceau (strokeShapegrass...), puis sous PressureMaping avec le
bouton droit de la souris cliquez PressureMin3 pour supprimer l'expression.

• Choisir la courbe de pression et la supprimer.

Attributs des brosses de type tube

Les plantes et les arbres sont de type tube. On a Accès a leurs paramétrés de formes dans le
noeud de brosse sous l'item Tubes.



Voyons la création d'une brosse tube de base : le bâton

Tube Completion On : Les tubes sont de même longueur le long du trait de la brosse

Tube completion Off les tubes s'amenuisent le long du trait

• Placez vous en mode canvas en appuyant sur la touche 8

• Affichez la fenêtre Attribut editor

• Faites : Painteffect->Reset tamplate brush

• dessinez un trait sur le canvas ou bien allez chercher une brosse de type arbre

• Dans le noeud des attributs de la brosse dans la partie tube placez les paramétrés suivants
:



• Vous pouvez sauvegarder cette brosse sous le nom de "bâton" dans votre shelf :

• Paint effect ->save presets

Une bonne facon d'evaluer les modifications des paramétrés est de choisir cette organisation de
travail,



Pour afficher rapidement le résultat des modifications, configurez les valeurs de résolution assez
basses

(Le curseur placé dans la zone Canvas appuyez sur la touche droite de la souri pour activer
Resolution=50%.

Puis verifiez que Stroke Refresh indique Rendered)

Essayez des valeures de ce type en activant la création de branches :





Les Attributs de croissances :

Vous pouvez definir l'orientation et le nombre de branches

les sous branches

les feuilles

les fleures

les bourgeons

Remarque sur les feuilles

Un scan de feuille peut être mappe. Sous leaves desactivez LeafUseBranch Text et allez chercher
une image de feuille

On retrouve la même méthode pour les fleures....



ANIMATION

L'animation des éléments se fait par déformation des tubes ou bien par application de
dynamiques aux tubes.

Sous l'item tube vous trouverez sous behaviour vous trouverez ;

Displacement, forces, turbulence, Spiral, Twist

 

Exemple d'animation d'un arbre par la turbulence

• En vue perspective, Créez un Plan : Create-> NurbsPrimitive->plane

• Mettez le a une echelle correcte

• Pour planter un arbre sur cette surface faites d'abord : PaintEffects->Makepaintable

• A partir du Visor , choisissez un arbre et plantez le !...

• Sélectionnez l'arbre,

• Ouvrez l'attribut editor. Sous le noeud de forme de l'arbre (strokeShapeTree_canvas par
exemple)

• Vous pouvez augmenter la qualité de l'objet en modifiant ObjectDisplay->Display
quality

• Sous le noeud de la brosse dans la partie Tube, sous behaviour vous trouverez l'item
Turbulence, donnez différentes valeurs pour voir les influences. A chaque valeur vous
pouvez donner une clef d'animation.



Exemple d'animation d'un arbre par une courbe

• (A partir de l'exemple précédent).

• Créez une courbe partant du bas de l'arbre et allant au haut de l'arbre

• Sélectionnez l'arbre et la courbe.

• Pour activer cette courbe de contrôle faites PaintEffects->CurveUtilities-
>SetStrokeControlCurve

• Curve Follow, Curve Attract, Curve Max dist sont les valeures qui regeront l'influence
de la courbe.

• Sélectionnez des CVs de la courbe . En les déplaçant vous modifierez la forme de l'arbre
:



• Si vous sélectionnez le plan et que vous le déplacez l'arbre sera contraint par la courbe.

Exemple d'influence du mouvement d'une forme sur les tentacules

• Ouvrez le fichier pfx_testla.mb

• Si vous jouez l'animation vous voyez que des lumières sont animées puis une boule plus
petite apparaît ...

• Sélectionnez la sphère nommée powerball et rendez la "paintable"

• Peignez sur cette surface quelques éclairs électriques



• Jouez l'animation

• Allez à la frame 100

• Sélectionnez les strokes (Edit->Select all by type-> Strokes)ainsi que la courbe37

• Puis faites : Paint Effects -> Curve Utilities -> Set Stroke Control Curves

• L'électricité sera attirée par la sphère montante : jouer l'animation autour des frames 100
et 150

• Sélectionnez maintenant la petite sphère.

• Rendez la "paintable", pour peindre encore de l'électricité...

• A partir de l'attribut editor de cette brosse modifiez les valeurs du shading afin d'obtenir
des eclairs violets et roses...



• Maintenant nous allons définir le moment ou la seconde boule commencera a émettre de
l'électricité. Toujours pour cette brosse sous Flow Animation nous pouvons établir :

 

Flow speed : représente la vitesse (en cycles par seconde) des effets de cisaillements, de
torsions, ainsi que le déplacement des textures le long des tubes animés. Les nombres positifs
font un écoulement à partir de la base. Les nombres négatifs font se développer les brosses du

bout vers la base.



Stroke time : permet l'animation de la croissance du début à la fin de la courbe "stroke" et cela
dansl'écart de temps défini par start time et end time.

Clip time : définit le début et la fin de l'animation du tube.

Start time etEnd Time sont exprimés en secondes. Si votre unité de temps est définie en 24i/s
par exemple (Options > General Préférences > Units), et que vous voulez commencer à la clef
80 vous devez alors entrer une expression dans le champ start time. écrivez : =80.0/24 (La clef
doit être exprimée en flottant : 80.0)


